Problema cargando una cinta con Spectaculator

Foro dedicado a la emulación de sistemas clásicos en el PC o en otros sistemas.
Avatar de Usuario
6128
Amiga 2500
Amiga 2500
Mensajes: 2793
Registrado: 27 Ene 2010, 18:06
Sistema Favorito: Amstrad CPC
primer_sistema: Amstrad CPC
consola_favorita: Sega Genesis/Megadrive
Primera consola: Sega Genesis/Megadrive
Ubicación: León
Gracias dadas: 73 veces
Gracias recibidas: 24 veces

Problema cargando una cinta con Spectaculator

Mensajepor 6128 » 20 Oct 2015, 12:12

Hace años que uso Spectaculator como emulador de Spectrum y todo bien, hasta ahora que me he encontrado con un juego que no carga y no sé por qué. Se trata del Zombo, juego que se publicó el pasado verano. Tengo el emulador configurado como ZX Spectrum 128 (he probado con todos los modelos de Spectrum y me pasa lo mismo). Cargo el archivo TAP descargado de la web del autor y me da error de lectura.

No sé dónde estará el fallo. Descargué un archivo RZX y he podido ver la videoguía sin problemas. :-k
Tengo también un archivo TZX pero ocupa bastante y el emulador directamente no lo coge.

Avatar de Usuario
na_th_an
Amiga 1200
Amiga 1200
Mensajes: 1270
Registrado: 10 Oct 2012, 11:17
Sistema Favorito: (Otro)
primer_sistema: Spectrum +2
consola_favorita: Sony PlayStation 1
Primera consola: Sega Master System
Gracias dadas: 18 veces
Gracias recibidas: 12 veces

Re: Problema cargando una cinta con Spectaculator

Mensajepor na_th_an » 20 Oct 2015, 13:35

No es un error, es que el juego empieza así.

Fíjate como luego la pantalla cambia a "(C) 2082 Government Research" y tras un par de segundos arranca el juego.

En Spectaculator, por cierto :)

Avatar de Usuario
6128
Amiga 2500
Amiga 2500
Mensajes: 2793
Registrado: 27 Ene 2010, 18:06
Sistema Favorito: Amstrad CPC
primer_sistema: Amstrad CPC
consola_favorita: Sega Genesis/Megadrive
Primera consola: Sega Genesis/Megadrive
Ubicación: León
Gracias dadas: 73 veces
Gracias recibidas: 24 veces

Re: Problema cargando una cinta con Spectaculator

Mensajepor 6128 » 20 Oct 2015, 18:59

Si. Empieza así. Depués sale ese mensaje que comentas. A continuación vuelve a salir un error de carga (de coña o real, no sé) y nada.

Avatar de Usuario
PabloMarmol
Amstrad PCW 8256
Amstrad PCW 8256
Mensajes: 142
Registrado: 03 Sep 2012, 17:32
Sistema Favorito: Spectrum 16Kb/48Kb
primer_sistema: Spectrum 16Kb/48Kb
Primera consola: Nintendo NES/Clónica
Ubicación: León, España
Gracias dadas: 6 veces
Gracias recibidas: 5 veces

Re: Problema cargando una cinta con Spectaculator

Mensajepor PabloMarmol » 20 Oct 2015, 21:28

si es un .tap el que intentas cargar, y el juego "tiene un momento de pausa mientras carga" (ese mensaje falso de error), tendrás que parar la cinta en ese momento (como se hacía con el spectrum real) :)

Avatar de Usuario
6128
Amiga 2500
Amiga 2500
Mensajes: 2793
Registrado: 27 Ene 2010, 18:06
Sistema Favorito: Amstrad CPC
primer_sistema: Amstrad CPC
consola_favorita: Sega Genesis/Megadrive
Primera consola: Sega Genesis/Megadrive
Ubicación: León
Gracias dadas: 73 veces
Gracias recibidas: 24 veces

Re: Problema cargando una cinta con Spectaculator

Mensajepor 6128 » 20 Oct 2015, 21:55

Tendré que probar a ver. Hasta la fecha he cargado muchos juegos de Spectrum en emulador y nunca me había encontrado con un caso así.

Avatar de Usuario
na_th_an
Amiga 1200
Amiga 1200
Mensajes: 1270
Registrado: 10 Oct 2012, 11:17
Sistema Favorito: (Otro)
primer_sistema: Spectrum +2
consola_favorita: Sony PlayStation 1
Primera consola: Sega Master System
Gracias dadas: 18 veces
Gracias recibidas: 12 veces

Re: Problema cargando una cinta con Spectaculator

Mensajepor na_th_an » 21 Oct 2015, 07:56

Yo no he tenido ningún problema, será que tengo las opciones diferentes en el navegador de cintas. Creo que yo tengo habilitado que se pare automáticamente. Podrías probar.

Es el tercer botón en el tape browser. Pone "Auto Play / Stop". Yo lo tengo activado:

zombo.jpg
zombo.jpg (218.33 KiB) Visto 2622 veces


Básicamente la carga se para tras el cargador BASIC, y luego prosigue normalmente para el resto de los bloques.

Avatar de Usuario
6128
Amiga 2500
Amiga 2500
Mensajes: 2793
Registrado: 27 Ene 2010, 18:06
Sistema Favorito: Amstrad CPC
primer_sistema: Amstrad CPC
consola_favorita: Sega Genesis/Megadrive
Primera consola: Sega Genesis/Megadrive
Ubicación: León
Gracias dadas: 73 veces
Gracias recibidas: 24 veces

Re: Problema cargando una cinta con Spectaculator

Mensajepor 6128 » 21 Oct 2015, 11:09

Diste en el clavo. Tenía esa opción activada entrando en el menú que comentas así que miré a ver si estaba marcada o no en Tools/Options/Cassette Recorder y no lo estaba. Ahora el juego carga correctamente. :jumper:

Gracias también a PabloMarmol pues efectivamente era cosa de pausar el cassette.


Volver a “Emuladores”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 2 invitados