Z80 para zx spectrum 48k issue 2

Sinclair QL, ZX81, +2, +3, 128K ...
Radiosity
Amstrad CPC 464
Amstrad CPC 464
Mensajes: 74
Registrado: 30 Oct 2015, 09:56
Sistema Favorito: Spectrum +2
primer_sistema: Spectrum +2
consola_favorita: Nintendo SNES
Primera consola: Nintendo SNES
Gracias dadas: 13 veces
Gracias recibidas: 14 veces

Z80 para zx spectrum 48k issue 2

Mensajepor Radiosity » 01 May 2017, 10:35

Hola compañeros.

Ha caido en mis manos una placa de un 48K que no arranca ni emite video ni nada. He comprobado los voltajes y estan todos OK: 12.02V, 5.01V y - 4.82V. La alimentacion llega bien tanto a memoria como a ULA, CPU y ROM. Estan cambiados TODOS los condensadores. Cuando conecto el teclado tampoco oigo los sonidos al pulsar las teclas por el altavoz por lo que intuyo que ni arranca. He probado una ULA exactamente igual y hace lo mismo. Con Dandanator para evotar ROM interna tambien se queda igual. Empiezo a sospechar que puede ser el Z80.

Mi idea es pillar 2 o 3 para tenerlos de reserva. Mi duda viene saber si puedo pillarlos de una frecuencia mas alta de trabajo como de 10 o 20 MHz o es mejor que sea igual al que lleva que si no me equivoco es de 4MHz. Es que el de 4 es mas dificil de encontrar.

Si os ocurre otra cosa que pudiera ser soy todo oidos.

Gracias y un saludo.

Radiosity
Amstrad CPC 464
Amstrad CPC 464
Mensajes: 74
Registrado: 30 Oct 2015, 09:56
Sistema Favorito: Spectrum +2
primer_sistema: Spectrum +2
consola_favorita: Nintendo SNES
Primera consola: Nintendo SNES
Gracias dadas: 13 veces
Gracias recibidas: 14 veces

Re: Z80 para zx spectrum 48k issue 2

Mensajepor Radiosity » 04 May 2017, 10:08

Ya he localizado la averia y mis sospechas desgraciadamente eran realidad. Era fallo de la ULA y del cristal de cuarzo de 14.000. La ULA esta completamente frita, probada en otra placa OK y con esta ULA ni arranca. El caso es que empece a probar 2 o 3 ULAs que me habian prestado y seguia sin arrancar hasta que me dio por cambiar el cristal de cuarzo. Despues de arrancar me dio fallo en la RAM baja 3 la que he cambiado.

saludos

JULIO
Commodore 128
Commodore 128
Mensajes: 117
Registrado: 22 Feb 2013, 18:58
Sistema Favorito: Spectrum +2
primer_sistema: Spectrum 16Kb/48Kb
Primera consola: TV Games/Pong Clone

Re: Z80 para zx spectrum 48k issue 2

Mensajepor JULIO » 30 May 2017, 05:49

Hola.
¿seguro que es la ULA?
¿cambiada en otra placa que tenia el mismo tipo exacto de ULA?
Una placa con una ULA 5c112 si le pones otras "mas moderna" no te arranca.
Según el tipo de ULA hay unos cuantos componentes que cambian.

Saludos.
Julio.

Radiosity
Amstrad CPC 464
Amstrad CPC 464
Mensajes: 74
Registrado: 30 Oct 2015, 09:56
Sistema Favorito: Spectrum +2
primer_sistema: Spectrum +2
consola_favorita: Nintendo SNES
Primera consola: Nintendo SNES
Gracias dadas: 13 veces
Gracias recibidas: 14 veces

Re: Z80 para zx spectrum 48k issue 2

Mensajepor Radiosity » 31 May 2017, 08:40

Si la cuestion es que poniendo otra ULA del mismo modelo exacto arranca perfectamente. Y con esa no. Esta claro que el cristal tambien estaba frito porque las primeras pruebas no me arrancaba con NINGUNA ULA da igual cual pusiese. Confirmado que es la ULA.

fnavarro
Spectrum 48K Plus
Spectrum 48K Plus
Mensajes: 35
Registrado: 05 Jun 2017, 21:09
Sistema Favorito: Amstrad CPC
primer_sistema: Spectrum 16Kb/48Kb
consola_favorita: (Otro)
Primera consola: Videopac
Gracias dadas: 16 veces

Re: Z80 para zx spectrum 48k issue 2

Mensajepor fnavarro » 07 Jun 2017, 16:16

Veo que ya lo has solucionado, según leía me cantaba a ULA frita porque me paso a mi hace poco en un gomas de un amigo (habían puesto la ULA al revés, que no se para que coña la quitaron). Sobre el micro, es un Z80A a 4,5 Mhz.


Volver a “Sinclair/Spectrum”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 2 invitados