Problema con RGB TTL en monitor Philips CM8501

Taller de hardware y cacharreo general de aparatos eléctricos y electrónicos que no tengan un sitio propio.
Avatar de Usuario
Quest
Atari 1040 STf
Atari 1040 STf
Mensajes: 900
Registrado: 18 Jul 2013, 22:20
Sistema Favorito: Commodore Amiga
primer_sistema: Spectrum 16Kb/48Kb
consola_favorita: Nintendo SNES
Primera consola: Nintendo NES/Clónica
Gracias dadas: 9 veces
Gracias recibidas: 13 veces

Problema con RGB TTL en monitor Philips CM8501

Mensajepor Quest » 17 Feb 2014, 20:05

Buenas,

Estoy teniendo un problema que no consigo entender por qué ocurre, a ver si podéis echarme un cable.

Resulta que ayer bajé al trastero a por mi viejo Commodore 1084s para aprovecharlo como monitor RGBI/TTL con mi commodore 128D o con los viejos PCs CGA. Luego me di cuenta mirando el submodelo que era un 1084s-D2, cuya entrada RGB din9 era sólo analógica. Hasta aquí correcto.

El tema es que visto lo anterior, lo volví a bajar, y me subí el otro monitor antiguo que tengo. Yo pensaba que era un Philips CM8833, pero no, resulta que es un CM8501, del cual no encuentro información por ningun lado. No obstante, no importa, ya que mirando por atrás veo que tiene una entrada SCART RGB, y luego una entrada marcada como TTL RGB de formato DIN8. Veo que los Philips de otras series, como la CM8833 tienen también este DIN marcado como RGB TTL así que entiendo que debería funcionar como tal, del mismo modo.

Como tengo un cable DB9<->DIN8, pruebo ilusionado, con mi commodore 128D a ver si funciona (en modo 80 columnas, claro). Lo enchufo y sale imagen, pero no se estabiliza en vertical, está moviéndose para arriba rápidamente y así se queda.

Compruebo el pineado del cable DB9<->DIN8 pin a pin con el multímetro, y todos los pines están conectados dodne deben estar (sincros H/V, colores, intensidad y masa).

Por si acaso es el C128, pruebo también con un par de antiguos XTs con salida CGA (tanto en 40 como en 80 columnas) y sucede exactamente lo mismo.

He mirado en el frontal y la trasera del monitor y los únicos ajustes que se pueden hacer son tamaño vertical y horizontal y posición. Ningún cambio lo arregla.

Si conecto cosas por la entrada SCART (Euroconector, y por tanto entiendo que RGB analógico), como por ejemplo un DVD, un Amiga 500 y demás, funciona perfectamente, con la imagen estable y definida.

¿Qué puede pasar? No logro entender por qué ocurre esto.

Pongo un par de fotos de la parte trasera y la imagen:

CM8501_RGB_TTL.jpg
CM8501_RGB_TTL.jpg (142.97 KiB) Visto 1949 veces


CM8501_mal_sincro.jpg
CM8501_mal_sincro.jpg (103.61 KiB) Visto 1949 veces


Gracias por adelantado!!!

Avatar de Usuario
Alucard_Saeba
MSX Turbo R
MSX Turbo R
Mensajes: 357
Registrado: 15 Jul 2009, 11:54
Sistema Favorito: Commodore Amiga
primer_sistema: PC
consola_favorita: Nintendo SNES
Primera consola: Sega Master System
Gracias dadas: 40 veces
Gracias recibidas: 32 veces

Re: Problema con RGB TTL en monitor Philips CM8501

Mensajepor Alucard_Saeba » 18 Feb 2014, 12:34

En el 8833 tienes un par de botones en la parte trasera ("Status RGB" y "VCR") para adaptar el tipo de RGB que le está entrando. Mira a ver si tienes por algún sitio de ese monitor algún control semejante.
Si te gustaría leer algo nuevo, prueba con Akasha Valentine.

Avatar de Usuario
Quest
Atari 1040 STf
Atari 1040 STf
Mensajes: 900
Registrado: 18 Jul 2013, 22:20
Sistema Favorito: Commodore Amiga
primer_sistema: Spectrum 16Kb/48Kb
consola_favorita: Nintendo SNES
Primera consola: Nintendo NES/Clónica
Gracias dadas: 9 veces
Gracias recibidas: 13 veces

Re: Problema con RGB TTL en monitor Philips CM8501

Mensajepor Quest » 18 Feb 2014, 14:38

Alucard_Saeba escribió:En el 8833 tienes un par de botones en la parte trasera ("Status RGB" y "VCR") para adaptar el tipo de RGB que le está entrando. Mira a ver si tienes por algún sitio de ese monitor algún control semejante.


Es lo primero que comprobé. No tiene ningún control de ningún tipo para ese menester, en ninguna parte de la carcasa.

Podría estar averiado?

Luna
Amiga 1200
Amiga 1200
Mensajes: 1630
Registrado: 01 Jun 2013, 16:21
Gracias dadas: 12 veces
Gracias recibidas: 8 veces

Re: Problema con RGB TTL en monitor Philips CM8501

Mensajepor Luna » 18 Feb 2014, 19:42

Tienes mal contacto en el V-Sync, si solo pasa con alguna maquina, revisa los contactos del cable, (Conector)
En el exilio.

Avatar de Usuario
Quest
Atari 1040 STf
Atari 1040 STf
Mensajes: 900
Registrado: 18 Jul 2013, 22:20
Sistema Favorito: Commodore Amiga
primer_sistema: Spectrum 16Kb/48Kb
consola_favorita: Nintendo SNES
Primera consola: Nintendo NES/Clónica
Gracias dadas: 9 veces
Gracias recibidas: 13 veces

Re: Problema con RGB TTL en monitor Philips CM8501

Mensajepor Quest » 18 Feb 2014, 19:58

No creo que sea eso. Comprobado ya con 4 máquinas distintas y mismo resultado. Además el cable y los conectores estan re-re-recomprobados. Digamos que (creo) que las cosas básicas ya están miradas y probadas: ajustes, potenciómetros, botones, cables, conectores....

Hasta abrí el monitor para ver la placa. Podría ser compartida con otros modelos de philips, puesto que hay hueco para el botón status rgb que tienen otros modelos, aunque evidentemente ni el botón ni los componentes están montados. Supongo que no hace falta, ya que el monitor tiene DOS entradas distintas: SCART RGB y TTL RGB, y por tanto no tendría mucho sentido que estuviera ese botón. Entiendo que estuviera para modelos que compartieran un único conector para ambas señales (como el CM883-II que sólo tiene una entrada la DB9, o el 1084s-P).

¿alguna idea de qué se puede medir o comprobar en la placa o en las señales?

Avatar de Usuario
jltursan
Amiga 2500
Amiga 2500
Mensajes: 3775
Registrado: 13 Oct 2006, 19:45
Sistema Favorito: MSX
primer_sistema: Dragon
Ubicación: Serracines, Madrid, España
Gracias dadas: 18 veces
Gracias recibidas: 58 veces
Contactar:

Re: Problema con RGB TTL en monitor Philips CM8501

Mensajepor jltursan » 18 Feb 2014, 20:43

Pues lo único que se me ocurre es que haya algo raro en el pinout del CM8501. Hasta donde yo se, la salida del C128 RGBI y la entrada TTL RGB (al menos la del primo 1084) son compatibles pin a pin. Por descartar tonterias, comprueba que el C128 no está fallando y que el nivel de los sincronismos es TTL (y ya de paso del resto de señales).

Aunque ya has probado con los equipos CGA, si pudieses echar mano de un 1084 auténtico, podrías descartar de golpe C128 y cable. Yo me decanto por que el monitor tiene algún defecto en el conector o simplemente porque el pinout es diferente. Suponiendo que "TTL RGB" represente lo mismo que en el 1084, podrías probar con otros pinout. En la foto que pones parece que los colores no son correctos, ¿por que no empiezas localizando cuales son cada uno de los componentes, sin sincronía y así descartar cosas?

Avatar de Usuario
Quest
Atari 1040 STf
Atari 1040 STf
Mensajes: 900
Registrado: 18 Jul 2013, 22:20
Sistema Favorito: Commodore Amiga
primer_sistema: Spectrum 16Kb/48Kb
consola_favorita: Nintendo SNES
Primera consola: Nintendo NES/Clónica
Gracias dadas: 9 veces
Gracias recibidas: 13 veces

Re: Problema con RGB TTL en monitor Philips CM8501

Mensajepor Quest » 18 Feb 2014, 22:18

Bueno, pues ya está arreglado :) Gracias a todos por responder.

El tema era bastante simple. He abierto de nuevo el monitor para comprobar el conector. Hallazgo: SOLDADURA FRÍA en el punto de la placa donde va el pin 8 (VSYNC) del conector DIN:

CM8501_soldadura_fria.jpg
CM8501_soldadura_fria.jpg (173.61 KiB) Visto 1875 veces


Repasito con estaño y todo perfecto :jumper:

Una partidita de Zork en el C128D a 80 columnas:

CM8501_Zork_C128D.jpg
CM8501_Zork_C128D.jpg (37.48 KiB) Visto 1875 veces


Y una partidita a prince of persia en el Sinclair PC200 con la CGA incorporada:

CM8501_POP_CGA.jpg
CM8501_POP_CGA.jpg (101.71 KiB) Visto 1875 veces


Ojalá todos los problemas fueran tan fáciles de solucionar como este :)

Saludos!


Volver a “Taller general”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 2 invitados