Log de reparaciones

Taller de hardware y cacharreo general de aparatos eléctricos y electrónicos que no tengan un sitio propio.
Avatar de Usuario
alt
Amiga 2500
Amiga 2500
Mensajes: 3192
Registrado: 07 Sep 2004, 21:52
Ubicación: madrid
Gracias dadas: 268 veces
Gracias recibidas: 406 veces
Contactar:

Re: Log de reparaciones

Mensajepor alt » 19 Feb 2018, 19:11

Paciente: Mega Drive II que no muestra imagen ni saca sonido.

Operación: repaso toda la placa en busca de algún integrado dañado o de óxido. Veo que algunos nodos están corroídos, los limpio, mido continuidad y compruebo que ninguno falla. Como son varios, estoy bastante convencido de que el fallo se va a deber a la oxidación de alguna pista o nodo.

Después de repasar toda la placa, caigo en la cuenta de que no he mirado debajo del conector de cartuchos. Ahí veo que una de las pistas que asoma está negra, pero con continuidad después de rasparla. Me pongo a medir continuidad en varias pistas cercanas a esa, intuyendo por dónde van por debajo del conector, hasta que encuentro una que no me pita con el polímetro. (Lo ideal sería mirar los esquemas eléctricos de la consola, pero al margen de que no sé si están publicados para este modelo y esta revisión, aún tengo el problema de que casi todas las pistas cruzan de una cara de la placa a otra a través de nodos (que no aparecen dibujados en el esquema), así que me ha tocado encontrar la rotura a ciegas).

Así que desueldo el conector y confirmo que tengo una pista partida. Y aprovecho para sacar fotos de la zona, por si alguien se encuentra alguna vez en la misma tesitura y tiene que buscar continuidad de un lado a otro del conector. ¡Ahora ya sabéis por dónde van las pistas y a qué nodos de los que hay en la zona!

Imagen

Imagen

Imagen

Imagen

El conector no solo va soldado patilla a patilla de todos los contactos, sino remachado. He tenido que meter la drémel para saltar los remaches. En la última imagen podéis ver dónde está mi avería, en la pista que va de R74 a la patilla 10 del procesador, justo en el tramo que va por debajo del conector. Un puente, y andando:

Imagen

Imagen

He preferido tirar un cable a reconstruir la pista porque temo que me rompan la reconstrucción con el meneo de meter y sacar los cartuchos.

Avatar de Usuario
alt
Amiga 2500
Amiga 2500
Mensajes: 3192
Registrado: 07 Sep 2004, 21:52
Ubicación: madrid
Gracias dadas: 268 veces
Gracias recibidas: 406 veces
Contactar:

Re: Log de reparaciones

Mensajepor alt » 30 Mar 2018, 12:11

Parece que este empiezxa a ser un fallo recurrrente en consolas de los años 90, desde la Mega Drive del mensaje anterior a la Game Boy, pasando por la SNES: aparecen manchas de corrosión en zonas concretas de la placa que se comen las pistas y producen fallos inclasificables (falta una "capa" de vídeo, se escucha un solo canal de sonido, etc.)

En este caso tenía una SNES a la que le faltaba un layer:

ANTES
Imagen

DESPUÉS
Imagen

En algunos juegos no se apreciaba el problema en absoluto y se podía jugar normalmente; en otros, como los que usan el chip Súper FX (y es el caso del Stunt Race) faltaban cosas como el logo de Nintendo, o el aviso de "Press start to play".

Entre los dos procesadores de gráficos, S-PPU1 y S-PPU2, había un auténtico "agujero" de corrosión, que se había llevado tres pistas. La reparación ha consistido, simplemente, en reconstruirlas.

Imagen

Imagen

Una inspección visual detenida empieza a ser muy importante a la hora de reparar estos chismes, incluso cuando la placa parece impecable y no tiene más restos de óxido.

Avatar de Usuario
marcos64
Amiga 1200
Amiga 1200
Mensajes: 1240
Registrado: 03 Sep 2011, 07:53
Gracias dadas: 16 veces
Gracias recibidas: 23 veces

Re: Log de reparaciones

Mensajepor marcos64 » 30 Mar 2018, 13:07

alt escribió:Parece que este empiezxa a ser un fallo recurrrente en consolas de los años 90, desde la Mega Drive del mensaje anterior a la Game Boy, pasando por la SNES: aparecen manchas de corrosión en zonas concretas de la placa que se comen las pistas y producen fallos inclasificables (falta una "capa" de vídeo, se escucha un solo canal de sonido, etc.)


Alguna idea de que causa la aparicion de la corrosion?
http://marcos64.orgfree.com/
Actualizacion 11/6/2015: Añadida Load'N'Run numero 3.

Avatar de Usuario
alt
Amiga 2500
Amiga 2500
Mensajes: 3192
Registrado: 07 Sep 2004, 21:52
Ubicación: madrid
Gracias dadas: 268 veces
Gracias recibidas: 406 veces
Contactar:

Re: Log de reparaciones

Mensajepor alt » 30 Mar 2018, 13:21

marcos64 escribió:Alguna idea de que causa la aparicion de la corrosion?


En los dos últimos casos, ni idea. La parte de la placa que está alrededor del conector de cartuchos es la más expuesta, pero en ninguna de esas dos consolas la pista cortada estaba directamente al aire. En la SNES, la zona afectada está debajo de la chapa metálica de la parte delantera de la consola, y no es accesible desde el puerto de cartuchos, ni le puede caer líquido desde fuera...

En las primeras Xbox, es habitual que se corte la pista de encendido, porque está muy expuesta a través de la rejilla de ventilación de la carcasa inferior; y un condensador o una pila con fugas puede causar un destrozo importante. Pero en estas consolas a las que me refiero (Mega Drive, SNES, Game Boy) aparecen manchas bastante inexplicables: no sabría decir si es a causa del proceso de fabricación, de que quedaron microburbujas de aire entre la placa y el barniz de protección, si es una reacción del barniz, o a causa del galvanizado de la chapa metálica que hace de jaula de Faraday, aunque esa chapa nunca está directamente en contacto con la placa salvo en el plano de masa...

Lo único que puedo decir es que no he visto cosas semejantes en consolas u ordenadores de la década previa, de los ochenta, a no ser que hayan estado expuestos a niveles muy altos de humedad, o se hayan mojado directamente. En el edge connector de los CPC y en las zonas adyacentes puedes encontrar de todo, pero es obvio que el daño ha sido causado por factores externos, no porque a la placa le dé de repente por pudrirse xD

Avatar de Usuario
marcos64
Amiga 1200
Amiga 1200
Mensajes: 1240
Registrado: 03 Sep 2011, 07:53
Gracias dadas: 16 veces
Gracias recibidas: 23 veces

Re: Log de reparaciones

Mensajepor marcos64 » 31 Mar 2018, 12:32

Por desgracia este tipo de cosas es algo a lo que habra que ir prestando atencion cada vez mas. Sobre todo si se encuentra alguna forma de evitarlo.

Pense que quizas el ambiente pudiera afectar si vives cerca del mar, pero leo que estas en Madrid, asi que queda descartado.

Por curiosidad, alguna vez has visto una pantalla LCD normal en que los segmentos 'encendidos' lo estan al 100%, y aquellos que deberian estar 'apagados' se quedan encendidos al 50%?
http://marcos64.orgfree.com/
Actualizacion 11/6/2015: Añadida Load'N'Run numero 3.

Avatar de Usuario
alt
Amiga 2500
Amiga 2500
Mensajes: 3192
Registrado: 07 Sep 2004, 21:52
Ubicación: madrid
Gracias dadas: 268 veces
Gracias recibidas: 406 veces
Contactar:

Re: Log de reparaciones

Mensajepor alt » 31 Mar 2018, 12:51

marcos64 escribió:Pense que quizas el ambiente pudiera afectar si vives cerca del mar, pero leo que estas en Madrid, asi que queda descartado.


Bueno, me llegan consolas para reparar de todo el Estado español; y sí, es más probable que las que proceden de zonas costeras tengan restos de corrosión. A veces abres una consola, y la única explicación que encuentras a lo que ves es que venga de un submarino xD

marcos64 escribió:Por curiosidad, alguna vez has visto una pantalla LCD normal en que los segmentos 'encendidos' lo estan al 100%, y aquellos que deberian estar 'apagados' se quedan encendidos al 50%?


No he visto algo como lo que describes, sino zonas desvaídas o con manchas; la culpa de esos fallos suele ser del polarizador, del acetato que se pone entre la pantalla y y el protector de la pantalla para "positivar" la imagen. El problema se arregla, normalmente, cambiándolo. Tengo en mente probar a sustituir los polarizadores de algunas Game&Watch con los de algunos teléfonos más o menos modernos que se tiran en el curro, a ver cómo quedan...

En cualquier caso, haz una prueba rápida con tu pantalla LCD: mírala pegando a la propia pantalla unas gafas de sol buenas, con los cristales polarizados, y comprueba que los segmentos o los puntos se dibujan correctamente.

Avatar de Usuario
marcos64
Amiga 1200
Amiga 1200
Mensajes: 1240
Registrado: 03 Sep 2011, 07:53
Gracias dadas: 16 veces
Gracias recibidas: 23 veces

Re: Log de reparaciones

Mensajepor marcos64 » 31 Mar 2018, 15:08

A ver que resultados obtienes con esas Game&Watch :) Mi intento de restauracion no tuvo el resultado esperado: http://www.zonadepruebas.com/viewtopic.php?f=11&t=5372&hilit=game%40watch

He probado a mirar el LCD con una lente polarizada y, dependiendo de las condiciones de iluminacion, el resultado varia desde no mejorar nada hasta solucionar por completo el problema. Curioso. En cualquier caso los segmentos activos se ven bien y los que deberian estar apagados son los que se encienden a media intensidad.

No es algo importante porque es un cuentakilometros de bici y no impide su funcionalidad, pero me preocuparia mas si le pasara a mis calculadoras.
http://marcos64.orgfree.com/
Actualizacion 11/6/2015: Añadida Load'N'Run numero 3.

Avatar de Usuario
alt
Amiga 2500
Amiga 2500
Mensajes: 3192
Registrado: 07 Sep 2004, 21:52
Ubicación: madrid
Gracias dadas: 268 veces
Gracias recibidas: 406 veces
Contactar:

Re: Log de reparaciones

Mensajepor alt » 25 Abr 2018, 13:37

Al que pueda interesar: hace unos días entró para reparar una Philips G7200. A causa de un golpe, las soldaduras del transformador de líneas se habían roto y este se había desprendido. Además, tenía un montón de condensadores secos, así que la imagen vibraba y no había manera de ajustarla a la superficie real del tubo. Al final conseguimos hacerla funcionar, pero quedaba un detalle: faltaba el mando deslizante de contraste.

Así que saqué la pieza de mi G7200, y un compañero, Emilio, la reprodujo; y luego otra compañera, Sandra, la imprimió. El resultado no es perfecto (le falta algún detalle, el biselado del borde por ejemplo), pero se parece bastante a la original y además es perfectamente funcional (encaja en la resistencia variable del contraste). Está descompuesta en cuatro partes para que no haya problemas al imprimir:

Imagen

Imagen

Imagen

Lo ideal es hacerla con plástico negro (de hecho, Sandra me ha sacado otros dos juegos de piezas en negro), pero la primera, en gris, que solo pretendía ser una prueba, quedó también que le saqué fotos. Es necesario mecanizar un poco lo que nos saca la impresora, sobre todo si es una Prusa de no mucha resolución: el poste normalmente queda más largo de lo necesario, y hay que recortarlo dos o tres milímetros por cada extremo. Y hay que lijar el contorno del mando, porque si no roza mucho dentro del vano. Para la muesca que indica dónde apunta el mando utilicé una drémel con un disco pequeño, y no queda mal del todo.

Adjunto el archivo con el diseño que hizo Emilio, para el que lo pueda necesitar (y, si alguien necesita la pieza y no tiene dónde imprimirla, a mí aún me queda un juego de piezas que le puedo dar).
Adjuntos
piezasv2.zip
(72.62 KiB) Descargado 5 veces

Avatar de Usuario
UFO
Atari 1040 STf
Atari 1040 STf
Mensajes: 789
Registrado: 19 Feb 2010, 15:16
Sistema Favorito: PC
primer_sistema: MSX
consola_favorita: Sega Genesis/Megadrive
Primera consola: Nintendo GameBoy
Ubicación: San Fernando (Cádiz)
Gracias dadas: 23 veces
Gracias recibidas: 3 veces
Contactar:

Re: Log de reparaciones

Mensajepor UFO » 29 Abr 2018, 12:10

Es alucinante cómo las impresoras 3D se van convertir en una herramienta a tener en cuenta a la hora de reparar/restaurar nuestras máquinas. Ha quedado de lujo! :D


Volver a “Taller general”

¿Quién está conectado?

Usuarios navegando por este Foro: mcleod_ideafix y 3 invitados