Resucitando un Amstrad PC5286

Emulación de sistemas DOS, Windows, DR-DOS, OS/2, Linux y sus sabores. Desde 8088 hasta Pentium 3.
Avatar de Usuario
Ikesankom
ZX Spectrum 16
ZX Spectrum 16
Mensajes: 11
Registrado: 22 Abr 2017, 21:54
consola_favorita: Sega Genesis/Megadrive
Primera consola: Nintendo NES/Clónica
Gracias dadas: 1 vez

Resucitando un Amstrad PC5286

Mensajepor Ikesankom » 22 Abr 2017, 23:07

Buenas noches. Recientemente me hice con un Amstrad PC5286. El problema que traía es que no funcionaba la fuente de alimentación. Traté de reparar la fuente mediante lo típico: buscando diodos quemados, condensadores hinchados etc.

Cambié dos o tres componentes pero la fuente seguía sin funcionar. Así que al final me decidí por que sería más rápido fabricarle una fuente nueva. He adaptado los componentes nuevos a la carcasa antigua y he sacado mediante una fuente Pico ATX las tensiones diversas: +12, +5, -12, etc.
Imagen

La cuestión es, que mediante la consulta a diferentes fuentes, creí haber dado con las tensiones necesarias para la placa. No obstante, he probado encender el equipo mediante unas tensiones sacadas de otro hilo de este foro: viewtopic.php?t=7606
Los -5 los he sacado con un rectificador a través de los -12. Sin embargo, aún no estoy seguro de que sean las tensiones correctas ya que el equipo se enciende (el led así lo indica) pero no hace nada más. Tengo dudas sobre todo con el conector pequeño.

Os mando una foto de los cables conectados a la placa a ver si podéis decirme cuáles son las tensiones correctas (los corté de la fuente antigua), por favor. Muchas gracias:
Imagen

Avatar de Usuario
Ikesankom
ZX Spectrum 16
ZX Spectrum 16
Mensajes: 11
Registrado: 22 Abr 2017, 21:54
consola_favorita: Sega Genesis/Megadrive
Primera consola: Nintendo NES/Clónica
Gracias dadas: 1 vez

Re: Resucitando un Amstrad PC5286

Mensajepor Ikesankom » 24 Abr 2017, 15:40

He probado poner en el conector pequeño ( contando como el rojo a la izquierda): -5,0,0,-12 y a la inversa -12,0,0,-5. De las dos formas el resultado es el mismo. Me parece muy raro que el fabricante utilizase un cable rojo y los demás grises, habiendo uno con diferente utilidad.
Se sigue quedando la luz verde de encedido estática pero no hay pitidos ni nada más. Espero que con el "experimento" no haya pasado nada (al fin y al cabo son corrientes negativas).
He pensado también la posibilidad de que la fuente no ofrezca el amperaje necesario (son 5A a 12V).
He buscado manuales técnicos y de otras gamas de Amstrad todo lo que queráis pero concretamente del PC5086 (que seguramente me valiera) o del PC5286 nada.

Avatar de Usuario
jltursan
Amiga 2500
Amiga 2500
Mensajes: 3757
Registrado: 13 Oct 2006, 19:45
Sistema Favorito: MSX
primer_sistema: Dragon
Ubicación: Serracines, Madrid, España
Gracias dadas: 15 veces
Gracias recibidas: 50 veces
Contactar:

Re: Resucitando un Amstrad PC5286

Mensajepor jltursan » 24 Abr 2017, 19:24

Hay una pregunta muy básica que te deberías hacer, ¿sabes 100% que el equipo funcionaba?. Es que igual el comportamiento que ves es el que corresponde a su estado...averiado.

Por lo demás, 5A a 12V no está mal para que la picoPSU aliemente un equipo como este, al menos para que de alguna señal de vida (ante la duda siempre deberías arrancarlo con absolutamente lo mínimo).
Lo de deducir que va en cada cable viendo la foto, eso sólo lo puede saber un poseedor de este equipo, a ver si alguien lo tiene y puede tomar la medida. No juegues mucho más con los voltajes, aunque sean negativos no es plan... ;)
Es curioso, ¿tiene separados los voltajes negativos de los positivos, al conector me refiero?. En principio creo que los +5V y +12V ya debería dar alguna señal de vida.

Avatar de Usuario
Ikesankom
ZX Spectrum 16
ZX Spectrum 16
Mensajes: 11
Registrado: 22 Abr 2017, 21:54
consola_favorita: Sega Genesis/Megadrive
Primera consola: Nintendo NES/Clónica
Gracias dadas: 1 vez

Re: Resucitando un Amstrad PC5286

Mensajepor Ikesankom » 24 Abr 2017, 19:38

jltursan escribió:Hay una pregunta muy básica que te deberías hacer, ¿sabes 100% que el equipo funcionaba?. Es que igual el comportamiento que ves es el que corresponde a su estado...averiado.

Por lo demás, 5A a 12V no está mal para que la picoPSU aliemente un equipo como este, al menos para que de alguna señal de vida (ante la duda siempre deberías arrancarlo con absolutamente lo mínimo).
Lo de deducir que va en cada cable viendo la foto, eso sólo lo puede saber un poseedor de este equipo, a ver si alguien lo tiene y puede tomar la medida. No juegues mucho más con los voltajes, aunque sean negativos no es plan... ;)
Es curioso, ¿tiene separados los voltajes negativos de los positivos, al conector me refiero?. En principio creo que los +5V y +12V ya debería dar alguna señal de vida.

Hola jltursan. Muchas gracias por contestar. Me imagino que esta fuente será común en muchos de los equipos PC de Amstrad. No creo que sea la específica del 5286. Lo único que creo que será casi seguro son las tensiones del conector grande (+5 en los morados, masa en los negros y +12 en el grande) y todo gracias al comentario del otro hilo. A ver si alguien me hace el ENORME favor de abrir su Amstrad, verlo y compararlo o simplemente decirlo si lo sabe de memoria :lol: .

Respecto a lo de si tiene los negativos separados. Tiene unos negativos en el conector grande (los negros de en medio) pero supuse que en el conector pequeño, algunos de los hilos también eran masa. Las placas base modernas también tienen varias masas. También podría ser un +5 el rojo del conector pequeño y el resto masas, pero ahí sí que no me la juego.

Estoy en ascuas precisamente por lo que dices, que el equipo pudiera estar tocado. Visualmente la placa tiene buen aspecto aunque por ejemplo, los condensadores que están cerca del conector, por debajo del chasis, no los puedo ver bien. Se enciende el LED de encendido pero no hace nada más. Al menos es algo :roll: .

Esto es el problema que surge de cuando aún no estaba tan estandarizado el tema de conectores en ordenadores, ni de códigos de colores, etc. y cada fabricante iba un poco a su libre albedrío.

Avatar de Usuario
xgipe
Atari 1040 STf
Atari 1040 STf
Mensajes: 826
Registrado: 26 May 2010, 15:59
Sistema Favorito: MSX
primer_sistema: MSX
consola_favorita: Sega Master System
Primera consola: Videopac
Ubicación: D.O. Penedès
Gracias dadas: 35 veces
Gracias recibidas: 29 veces

Re: Resucitando un Amstrad PC5286

Mensajepor xgipe » 25 Abr 2017, 15:05

A ver, no sé si te será de ayuda... :-k
en el vídeo puede verse la fuente original y sus cables de conexión (Minuto 8.50).




Suerte...
BLOAD "CAS:",R
Found: WIN3.11

Avatar de Usuario
Ikesankom
ZX Spectrum 16
ZX Spectrum 16
Mensajes: 11
Registrado: 22 Abr 2017, 21:54
consola_favorita: Sega Genesis/Megadrive
Primera consola: Nintendo NES/Clónica
Gracias dadas: 1 vez

Re: Resucitando un Amstrad PC5286

Mensajepor Ikesankom » 25 Abr 2017, 16:15

Hola xgipe. Muchas gracias por el vídeo. Al parecer, intuye las tensiones, pero no las sabe exactamente y sólo habla del conector grande. La única opción es que pudiera comprobarlo con un polímetro.


Volver a “PC Clásico”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 2 invitados